Issue accessing Help Desk
Incident Report for The Advert Platform
Resolved
This incident has been resolved.
Posted about 2 years ago. Mar 21, 2017 - 07:10 GMT
Identified
The help desk is currently offline. We are aware and are working on a fix.
Posted about 2 years ago. Mar 20, 2017 - 22:34 GMT