Unplanned maintanance
Incident Report for The Advert Platform
Resolved
The issue with the Postcode Lottery has been resolved and you should be able to view and claim as normal! Good luck!
Posted over 1 year ago. Nov 14, 2017 - 10:10 GMT
Identified
The lotto is currently offline for unplanned maintenance. We will post updates when they become available.
Posted over 1 year ago. Nov 03, 2017 - 11:39 GMT