HTTPS Certificate issue
Incident Report for The Advert Platform
Resolved
HTTPS functionality has been restored site wide
Posted 7 months ago. Oct 01, 2018 - 19:55 BST
Identified
We are looking into this and will update in due course.
Posted 7 months ago. Sep 28, 2018 - 13:12 BST
This incident affected: The Advert Platform - Website, Customer Support (Helpdesk), and Payment Processors (Bitcoin).