MAP Holding not responding
Incident Report for The Advert Platform
Resolved
We have resolved this server issue and users can now access MAP Holding.
Posted about 2 years ago. Apr 10, 2017 - 12:59 BST
Identified
We have identified that MAP Holding is currently offline and have dispatched our techs to fix.
Posted about 2 years ago. Apr 09, 2017 - 23:52 BST