BTC Network Delay
Incident Report for The Advert Platform
Resolved
This incident has been resolved.
Posted over 1 year ago. Nov 17, 2017 - 14:25 GMT
Identified
The BTC network is currently operating at reduced capacity. Inbound and outbound transactions may remain pending longer than expected. Customers should anticipate a significant delay for any BTC transactions.
Posted over 1 year ago. Nov 13, 2017 - 11:26 GMT